Ticket #56 (closed defect: invalid)

Opened 6 years ago

Last modified 6 years ago

DB changes inside of event handlers not affecting DB

Reported by: guest Owned by: ged
Priority: major Milestone:
Component: core Version:
Keywords: Cc: matthew@…

Description (last modified by ged) (diff)

Possibly related to: r286

There's a patch for the test_events.py attached, but not a fix sorry. I don't know how to fix it :)

Attachments

events.patch (3.1 kB) - added by guest 6 years ago.

Change History

Changed 6 years ago by guest

Changed 6 years ago by guest

Sorry not #286 but [286]

Changed 6 years ago by ged

  • status changed from new to closed
  • resolution set to invalid
  • description modified (diff)

The problem is that you cannot insert any new instances at this point through the ORM. You can do "raw" SQL inserts and such, or modify the instance values, but not add new instances. See the various comments in the corresponding mapper extensions methods at: http://www.sqlalchemy.org/docs/05/sqlalchemy_orm.html#docstrings_sqlalchemy.orm_MapperExtension

Note: See TracTickets for help on using tickets.